I've been encountering a number of problems with the Mila passes over my last couple scenes and am struggling to find anything in forums that can help.

1), occasionally they come out black. but not every pass only single materials in a pass.
I have a scene made up entirely of Mila shader. and when i render everything is fine in the RGBA, but when i jump into the passes, Direct Diffuse, Direct_Diffuse_Light_Sets1234, mila matte passes, some objects are missing. now i've seen that before when a single material is mia or lambert. but all shaders are mila.
They do correlate though, if they are not in direct_diffuse, they also have black in their matte pass.

I have traced their framebuffer paths in the miDefaults to see if anything had become disconnected after Maya created their links, and everything seems connected properly.
The matte utility is connect to the color of Extra Color[0] and Color Fb points to the correct matte_mila framebuffer which is correctly linked to the mentalrayOutputPass and Renderable is checked.
Nothing appears to be different to the objects/materials that do appear in the passes.

2) another problem i've encountered is sometimes the Mila materials work fine, appear in the RGBA, diffuse and light set passes, but have no matte_mila pass created.
When i have turned on use mila matte passes in render settings, a matte utility has been created, the mila_material points to a created framebuffer, but when you look in miDefaultOptions there is no tab for that framebuffer or pass.
I have tried creating a new framebuffer and OutputPass and attached the created matte utility, and added output pass to cameras Output Shaders, but they just come out black.

Is there a better way to view the framebuffers and passes, like hypershade, to see connections and make sure things are correctly properly? It seems a very difficult system to debug if there's errors.

If anyone knows how to get matte sets to work also please let me know, i've seen videos where people just click use 'matte pass material sets' in render settings and select the elements they want in that set and it works. This has never worked for me.

This whole system is quite new to me, recently transferred from 2012 to 2016, and don't quite know the ins and outs of how everything is connected, and there seems to be very little documentation online, so Any help would be greatly appreciated.