Results 1 to 6 of 6

Thread: errors using DBR rendering

  1. #1
    Join Date
    Jul 2015
    Posts
    47

    Default errors using DBR rendering

    When I render with satellite (distributed bucket rendering) I have that error in the MR console :

    LINK 2.n 5 MB error 191007: cannot load ..\..\Shaders\shaders_autoload\mentalray\shaders/PointCloudShader.dll, The specified module could not be found.
    LINK 2.n 5 MB error 191012: Unable to link file "PointCloudShader.dll".

    I don't use this shader in my scene.
    I checked on the pc that I use for DBR and the dll is at the right place... Does it have to do with a .mi file?
    same version of MR 3.14.1.4

    Thanks

  2. #2
    Join Date
    Jul 2015
    Posts
    47

    Default

    Still the same error :
    LINK21.n 5 MB error 191007: cannot load ..\..\Shaders\shaders_autoload\mentalray\shaders/PointCloudShader.dll, The specified module could not be found.
    LINK21.n 5 MB error 191012: Unable to link file "PointCloudShader.dll".
    MSG 0.0 176 MB warn : expected structure "E" missing from "G" shader declaration
    MSG 0.0 179 MB warn : expected structure "E" missing from "G" shader declaration
    MSG 0.0 179 MB warn : expected structure "E" missing from "G" shader declaration

    Any help would be nice from nvida...
    thanks

  3. #3
    Join Date
    Dec 2004
    Location
    Marina Del Rey, California
    Posts
    4,143

    Default

    It works fine without satellite rendering?

    The satellite uses the rayrc to determine where to find shaders_autoload dlls and mi include files.

    Are you sure that the PointCloudShader mi declaration and dll files are matched on the satellite the same as on the local host?

    shaders_autoload is not filled by NVIDIA.
    Barton Gawboy

  4. #4
    Join Date
    Jul 2015
    Posts
    47

    Default

    I copied my autoload folder to the other pc. But no change.
    There is one thing : Should mi file be named the same as the dll? Because for that specific one, there are not.
    I have PointCloudShader.dll and autodeskPointCloudShader.mi
    I renamed the mi file, but no change, still the same error...
    If I select dbr but none of my server, I have that message which is the same but without the PointCloudShader.dll error
    MSG 0.0 424 MB warn : expected structure "E" missing from "G" shader declaration
    MSG 0.0 424 MB warn : expected structure "E" missing from "G" shader declaration
    MSG 0.0 424 MB warn : expected structure "E" missing from "G" shader declaration
    MSG 0.0 426 MB warn : expected structure "E" missing from "G" shader declaration
    MSG 0.0 428 MB warn : expected structure "E" missing from "G" shader declaration
    MSG 0.0 428 MB warn : expected structure "E" missing from "G" shader declaration

    Any idea?

  5. #5
    Join Date
    Jul 2015
    Posts
    47

    Default

    the image renders fine, so I guess it is not a huge error...
    And as you said, it is relevent to autodesk and not nvidia. I can live with it.

    thanks

  6. #6
    Join Date
    Dec 2004
    Location
    Marina Del Rey, California
    Posts
    4,143

    Default

    Oops shaders_autoload is also not from Autodesk. It is something that a customer or a third party fills.
    Barton Gawboy

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •