Results 1 to 2 of 2

Thread: Mental Mill v1.0 availability.

  1. #1
    Join Date
    Aug 2009
    Location
    The West
    Posts
    12

    Default Mental Mill v1.0 availability.

    Hi!

    The current project we are on uses 3dsMax 2010 and I'd like to construct prototype shaders in MetaSL for Max 2010. I believe shaders created in Mental Mill v1.1 are not compatible with 2010 so is Mental Mill Standard Edition v1.0 still available so that I can do this?

    Thanks,

  2. #2
    Join Date
    Jun 2007
    Location
    Berlin
    Posts
    754

    Default

    The answer is yes and no. In mental mill 1.1 the xmsl format has been updated to acommodate new mechanisms like Material Definitions which don't exist in mental mill version 1.1. That said, if you load an .xmsl file in the DirectX shader of 3ds Max 2011 it will report a wrong xmsl version. This can easily be fixed by changing the 2nd line of the saved xmsl file from
    Code:
    <version major="2" minor="0"/>
    to
    Code:
    <version major="1" minor="0"/>
    As long as you restrict your work to using 1.0 features (creating Phenomena and not using Material Definitions) the scenes are compatible.
    You could automatize this using a script to process your exported files. This is not the best solution as it would be preferrable to export 1.0 backwards compatible files, but that way you can get your 1.1 scenes working with 3ds Max 2010.

    Regarding the availability of mill 1.0 I will come back to you as soon as possible.

    Best Regards,
    RĂ¼diger

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •