Results 1 to 3 of 3

Thread: No alpha in render channels when using mia_material

  1. #1
    Join Date
    May 2011

    Question No alpha in render channels when using mia_material

    Hi there,

    I got a problem that drives me mad:

    If I use the mia_architectural shader (mia_material or mia_material_x) and specify some render channels like Diffuse, Reflection, etc, the alpha in the render channels is totally black except in the Main render channel. So the render channels appear empty in the compositing program.

    If I use a Phong or Lambert everything works as expected. So something seems to be different with mia_material.

    So is there a special option I have to activate/deactivate when using the mia_material or a special way to set up framebuffers?

    Thanks for any help!.

    Best regards

  2. #2
    Join Date
    Apr 2009


    the mia_mat_x from the mental ray drop down menue in the rendertree does not render framebuffers, had the same problem in 2011 (did not tested it in 2012). but the normal mia_mat (multiout) from the illum dropdown works like expected.
    have you tryed custom framebuffer setup in rendertree with mia multiout?

  3. #3
    Join Date
    May 2011


    Hi Kzin,

    I tested it with the Architectural (Multi-Out) from the Illumination tab as you suggested, but it still is not working. I get no alphas in the framebuffers.
    I even tried to set it up with the above shader and a custom framebuffer set (store color in channel & mix 8 nodes) but still no success.

    So I started to render it out without an alpha (by setting the render channels from RGBA to RGB) and tried to compose the framebuffers in Toxik by using the alpha from the Main render channel.
    I always get a dark border around the edges of the objects. So the alpha also doesn't seem to fit.

    I attached the test scene so everybody can play with it.
    Maybe there is someone who can press the right buttons to get this work.

    Either it's me who still does not understand how mental ray works (after several years of excessive use) or it simply doesn't work with the tools provided.

    Would be great to have a solution soon since this is something I need in my every day work.
    It's kinda strange that I seem to be the only one who addresses this.
    Attached Files Attached Files

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts